Over the last month there has been some concern over the read performance of Samsung’s 840 EVO drives, and whether after Samsung’s previous performance fix, that these same drivers are starting to regress in performance once again. Since then we have been pressuring Samsung for additional information on the issue and a response, and this afternoon Samsung has finally issued a statement on the matter.

In October, Samsung released a tool to address a slowdown in 840 EVO Sequential Read speeds reported by a small number of users after not using their drive for an extended period of time. This tool effectively and immediately returned the drive’s performance to normal levels. We understand that some users are experiencing the slowdown again. While we continue to look into the issue, Samsung will release an updated version of the Samsung SSD Magician software in March that will include a performance restoration tool.

As a reminder, the original 840 EVO performance degradation issue was a result of a combination of NAND cell charge decay and NAND management algorithm issues. While NAND cell charge decay is a normal part of NAND operation, it was something Samsung’s more complex TLC NAND was more sensitive to. Meanwhile Samsung’s algorithms, when faced with this decay, erroneously went into an aggressive read-retry state, which is ultimately what lead to the drop in read performance. Samsung’s fix in turn addressed their NAND management algorithm, and at least at the time was thought to be a permanent fix for the issue.

These more recent performance issues and now Samsung’s statement make it clear that the issue is unfortunately not as fixed as Samsung initially thought it would be. At this point Samsung isn’t saying what the root cause of this latest issue is, but it’s likely that this is a continuation of the original issue. In any case the upshot is that Samsung believes the issue can be corrected, however given the last fix it’s not clear whether this next fix will be any more a permanent fix than the last one.

Source: Samsung (via email)

POST A COMMENT

75 Comments

View All Comments

  • npz - Monday, February 23, 2015 - link

    What cpu and which chipset?

    It only works a very few select AMD chipsets.
    The DOS version does not work and will crash in fact. AM1/Kabini does not work (ahci nor ide) nor do older AM2/3 boards.
    Reply
  • iceblitzed - Sunday, February 22, 2015 - link

    Potential Temp fix:

    There is a program for windows called disk fresh.

    What it does is it does a rewrite of your whole drive.
    Reply
  • kgh00007 - Saturday, February 28, 2015 - link

    Yep, this works a treat! It restored my performance to around 350MB/s from below 50MB/s on parts of the drive. So worth using once in a while when performance drops until this problem is resolved. Reply
  • cerunnos - Sunday, February 22, 2015 - link

    They really need to fix this issues for models other than the EVO as well. This is my laptop after about a year of extremely light usage (a few times a month tops, mostly browsing and typing on the go). The performance drop is massive, programs like Chrome, Word, and even Windows now take noticeably longer to boot up. Bechmarks that read/write new data show 400+ reads.

    http://s13.postimg.org/wzfuctmpz/hdtach_samsung_fl...
    Reply
  • poohbear - Monday, February 23, 2015 - link

    well, atleast they're not dodging the question and trying to address the issue. I have 2 Samgung 840 Evos, part of buying the 2nd was Samsung's brandname and established reliability that came with that. So i hope they follow through on their reputation. Reply
  • OnBoard - Tuesday, February 24, 2015 - link

    I didn't learn.. I bought 840 EVO to fix my 840 vanilla as they said it's fixed now..
    840 (vanilla) http://imgur.com/dYJFuTt (you guys need to fix that still too)
    840 EVO new http://imgur.com/VUY3DkK
    840 EVO now 2months old http://imgur.com/WBUHUN2
    Reply
  • bg17aw - Saturday, February 28, 2015 - link

    Hey, what about the 840 drives??? I have one, and an Evo. I need both of them fixed! Reply
  • roadmalum - Sunday, March 15, 2015 - link

    Another temp fix: Run Spinrite on level 3 on your 840 EVO drive.

    Before: http://postimg.org/image/nh3i7o2xj/

    After: http://postimg.org/image/jd6upwp65/
    Reply
  • SputBob - Tuesday, March 31, 2015 - link

    We'll, March has come and gone... Reply
  • jellowiggler - Thursday, April 2, 2015 - link

    Where is that Magician with the fix in it? It's April 2 and the new version isn't here.
    I understand the there could be complex tecnhnical issues at play here. But this has been going on since late summer 2014. The first fix attempt was in the Fall. What gives?

    I will not be buying Samsung again. Crucial M series or Intel?
    Reply

Log in

Don't have an account? Sign up now